*chattr +i /etc/resolv.conf*: RISOLTO/SOLVED con/with dhcpcd

\/ ENGLISH AT BOTTOM \/

Qualche volta, il comando *chattr* non funziona. Il motivo piu' comune e' il tipo di filesystem non supportato dal programma. Errore tipico: *chattr: Inappropriate ioctl for device while reading flags on /percorso/al/file*. Puppy Linux e' un buon esempio, con il suo *unionfs*.
Per ovviare, si può scrivere sul filesystem dall'esterno (con un altro sistema operativo), oppure, come nel caso di */etc/resolv.conf*, affidarsi alla peculiarita' del programma che vi inserisce dati, ovvero dhcpcd.
Il problema e' la sovrascrittura automatica di /etc/resolv.conf da parte di dhcpcd, ad ogni connessione di rete. L'obiettivo e' mantenere, invece, sempre gli stessi DNS. Si puo' procedere in molti modi, tra i quali creare un file chiamato */etc/resolv.conf.head*:

SINTASSI

nameserver + IP del DNS

ESEMPIO
nameserver 1.2.3.4 #dns.1
nameserver 4.3.2.1 #dns.2

Per la gestione completa del file /etc/resolv.conf, clicca qui.

Prosit! :)



\/ ENGLISH \/

Sometimes, *chattr* fails. The most common reason is a not supported filesystem type. Typical error: *chattr: Inappropriate ioctl for device while reading flags on /path/to/file*. Puppy Linux is a good example, with its *unionfs*.
To bypass, write from the outside (by another operative system), or, as in case of */etc/resolv.conf*, entrust peculiarity of the program that insert data to it, that is *dhcpcd*.
Problem is /etc/resolv.conf automatic overwriting by dhcpcd, at every network connection. Goal is maintain, instead, always the same DNS. Among many ways to proceed, name a file */etc/resolv.conf.head*:

SYNTAX

nameserver + DNS IP

EXAMPLE
nameserver 1.2.3.4 #dns.1
nameserver 4.3.2.1 #dns.2

Click here for a comprehensive handling of /etc/resolv.conf.

Prosit! :)


(Fonte immagine/image from: bilisimzirve.com)

Posted on 24 Jan 2014, 5:28 - Category: System
No comments - Edit - Delete


Postfix, *Client host rejected: cannot find your hostname*: RISOLTO/SOLVED


\/ ENGLISH AT BOTTOM \/

Molti post suggeriscono di togliere *reject_unknown_client_hostname* (se lo si e' inserito nella propria configurazione Postfix (/etc/postfix/main.cf), alla voce *smtpd_client_restrictions*), per ovviare al problema della mancata consegna di mail legittima, ma non occorre.
Puo' bastare anche solo cambiare i DNS in uso, responsabili di non risolvere alcuni nomi host.
Per verificare la propria condizione, occorre lanciare sul mail server, da CLI, una risoluzione del nome a dominio per l'IP che Postfix registra come *unknown* nei log.

Sintassi con il comando nslookup:

nslookup [IP] + [INVIO]

(esegue la ricerca sui DNS del proprio ISP)

nslookup [IP] + [NOME A DOMINIO DI UN DNS ALTERNATIVO] + [INVIO]

(esegue la ricerca su un DNS specifico - attenzione a non mettere un IP! -)

Se sulla propria distribuzione e' presente, si puo' utilizzare anche il comando host, con la stessa sintassi.
Se il risultato della query DNS non contiene il nome a dominio, e' necessario commentare i name server dell'ISP e mettere quelli alternativi nel file /etc/resolv.conf.

Puo' essere utile, infine, per proteggere il file /etc/resolv.conf da sovrascritture, per esempio dovute ad un riavvio del sistema o rilancio della connessione:

chattr +i /etc/resolv.conf

Clicca qui per una lista di DNS italiani

Prosit! :)



\/ ENGLISH \/

Many posts suggest to remove *reject_unknown_client_hostname* (if you inserted it in your Postfix configuration (/etc/postfix/main.cf), under the heading *smtpd_client_restrictions*), to compensate for legitimate mail failed delivery, but it's unnecessary.
Changing DNS in use, guilty to not resolve some name hosts, is enough.
Verify your condition by launching from CLI, on the mail server, a domain name resolution for IP that Postfix detects as *unknown* into logs.

Nslookup command syntax:

nslookup [IP] + [ENTER]

(performs a query on ISP DNS)

nslookup [IP] + [ALTERNATIVE DNS DOMAIN NAME] + [ENTER]

(performs a query on the specific DNS - pay attention, do not type an IP! -)

If in your distribution host command is present, you can use it with the same syntax.

If DNS query output doesn't contain domain name, you need to comment out ISP name server and put alternative ones into /etc/resolv.conf file.

It can be useful, at last, protect /etc/resolv.conf from overwriting, in example due to reboot or connection relaunch:

chattr +i /etc/resolv.conf

Click here for a worldwide DNS list

Prosit! :)


(Fonte immagine/image from: http://ts1.mm.bing.net/th?id=H.4886840784323116)

Posted on 15 Jul 2014, 2:15 - Category: Mailservers
No comments - Edit - Delete


Puppy Linux webserver software: hiawatha-9.3.pet


\/ ENGLISH AT BOTTOM \/

Disponibile, nel mio repository, l'attuale Hiawatha come pacchetto pet, fino alla nuova versione, dalla quale verra' sovrascritto.
N.B. hiawatha.conf e' stato rinominato in hiawatha.conf.default-example, per evitare indesiderate sovrascritture nel sistema.

Prosit! :)



\/ ENGLISH \/

Available, in my repository, current Hiawatha pet-packed, up to newer version, from which will be overwritten.
Please, note: hiawatha.conf has been renamed in hiawatha.conf.default-example, to avoid undesired overwriting in your system.

Prosit! :)


(Fonte immagine/image from: http://ts1.mm.bing.net/th?id=H.4761779823641860)

Posted on 1 Dec 2013, 5:57 - Category: Webservers, PHP, MySQL
No comments - Edit - Delete


Puppy Linux software, Adobe Flash Player pet: Adobe-Flash-Player-11.2.202.327.i386.pet download

\/ ENGLISH AT BOTTOM \/

Disponibile da oggi, nel mio repository, l'attuale ultimo Adobe Flash Player come pacchetto pet (fino alla nuova versione, dalla quale verra' sovrascritto). Qualsiasi browser dovrebbe automaticamente vedere il nuovo plugin. La sola raccomandazione e' di riavviare il browser dopo l'installazione del pet, altrimenti non sara' possibile riscontrare come attiva la nuova versione (in caso di verifica, a browser non riavviato, vedrete ancora quella vecchia, se in uso). Per controllare il buon esito dell'installazione, il riferimento e' l'apposita pagina del produttore e proprietario del software, ovvero quella di check di Adobe Flash Player:

http://www.adobe.com/software/flash/about

NOTA BENE: con hardware datato, le ultime versioni di Flash Player possono non funzionare. Nel caso, disinstallate questo pet e provate quello reso disponibile dalla community di Puppy sul suo forum:

http://www.murga-linux.com/puppy/viewtopic.php?t=77256


Prosit! :)



\/ ENGLISH \/

Available since today, in my repository, current last Adobe Flash Player pet-packed (up to newer version, from which will be overwritten). Any browser should automatically see the new plugin. The only recommendation is to restart your browser after installing the pet, or new version can not be found active (in case of inspection, with no browser restart, you'll still see the old one, if used). To verify successful installation, reference is the appropriate page of the producer and owner of the software, that is check page of Adobe Flash Player:

http://www.adobe.com/software/flash/about

PLEASE, NOTE: on old hardware, last Flash Player versions may not work. In this case, uninstall this pet and try that one made available by Puppy community through its forum:

http://www.murga-linux.com/puppy/viewtopic.php?t=77256


Prosit! :)


(Fonte immagine/image from: http://cdn-static.zdnet.com/i/story/62/58/001633/adobe-flash-player-icon.jpg)

Posted on 22 Nov 2013, 2:29 - Category: Plugins
No comments - Edit - Delete


Puppy Linux wireless solved: BCM4312

\/ ENGLISH AT BOTTOM \/

Inserite

rfkill unblock all

in /etc/rc.d/rc.local e poi riavviate.

Prosit! :)



\/ ENGLISH \/

Insert

rfkill unblock all

in /etc/rc.d/rc.local, then reboot.

Prosit! :)


(Fonte immagine/image from: http://1.bp.blogspot.com/-_2FuShb8ItY/UNZHg0Df-YI/AAAAAAAAANU/fpZjLc_mPwQ/s1600/linux_wi-fi.jpg)

Posted on 20 Nov 2013, 4:07 - Category: WIFI
1 Comment - Edit - Delete


Puppy Linux software: qemu-1.5.3_x86.sfs, qemu-1.6.0_x86.sfs

\/ ENGLISH AT BOTTOM \/

Disponibili, nel mio repository, gli ultimi due Qemu come pacchetti sfs, fino alla nuova versione, dalla quale verranno sovrascritti.

Prosit! :)



\/ ENGLISH \/

Available, in my repository, latest two Qemu sfs-packed, up to newer version, from which will be overwritten.

Prosit! :)


(Fonte immagine/image from: http://ts1.mm.bing.net/th?id=H.4570778373521516)

Posted on 6 Sep 2013, 1:14 - Category: Emulators, virtualizers
1 Comment - Edit - Delete


Puppy Linux software: Xbatalarm-1.2_x86.pet



\/ ENGLISH AT BOTTOM \/

Xbatalarm è nato da una collaborazione di famiglia. Potrei chiamarlo il primo vero frutto del *QuaLaPinna Team*. ;)
L'ho gia' presentato nel *Puppy Linux Discussion Forum* e questo e' il link diretto:
http://www.murga-linux.com/puppy/viewtopic.php?t=85475.
Al momento, ho notizia che Xbatalarm e' stato incluso nelle distribuzioni *Puppy-es Night RC* e *XOpup*, basate su Puppy Linux.
Riassumendo, si tratta di un'utilita' di monitoraggio della batteria, per laptop con Puppy Linux a bordo.

Vantaggi:

- molto leggero, puo' coesistere con la powerapplet tray di default
- gira in background e notifica, via pop-up e avviso sonoro, quando il livello di carica scende sotto il 15% dell'ultima capacita' massima rilevata (e non quella dichiarata originariamente dal produttore. Utile per le vecchie batterie)
- supporto per batterie diverse
- supporto linguistico (NLS, pacchetti opzionali).

Da sapere:

- e' utile (ma non indispensabile) riavviare X per assicurarsi che Xbatalarm sia stato lanciato dopo l'installazione (o aprire un terminale e verificare). Per alcuni notebook e' necessario.
- se disinstallato, necessita il riavvio di X o del computer, per terminare il monitoraggio.
- l'immagine ha il solo scopo di mostrare come il programma funziona, poiche' questo non necessita di essere lanciato da terminale nel suo uso comune.

Prosit! :)

\/ ENGLISH \/

Xbatalarm was born from a family collaboration. I could call the first real fruit of the *QuaLaPinna Team*. ;)
I already introduced it into *Puppy Linux Discussion Forum* and this is direct link:
http://www.murga-linux.com/puppy/viewtopic.php?t=85475.
At this time, I know that Xbatalarm has been included in *Puppy-es Night RC* and *XOpup* distributions, based on Puppy Linux.
To sum up, it's a battery monitor utility, for laptops with Puppy Linux on board.
Image only wants to show how this program works, because this one doesn't need to be launched into a terminal in everyday's use.

Advantages:

- very light, it can coexist with default powerapplet tray
- it runs in background and notify you, via pop-up and acustic warning, when charge level goes under 15% of the last capacity detected (and not that one declared initially by manufacturer. Useful for old batteries)
- support for different batteries
- linguistic support (NLS, optional packages).

To know:

- it's useful (but not essential) restart X to be sure that Xbatalarm was started after installation (or open a terminal and verify). Some notebooks need that.
- if you'll uninstall, please restart X or reboot your computer to stop monitoring.
- image only wants to show how this program works, because this one doesn't need to be launched into a terminal in everyday's use.

Prosit! :)



Posted on 2 Sep 2013, 21:54 - Category: Laptop utilities
1 Comment - Edit - Delete


Puppy Linux software: dia-0.97.2.pet, dia_NLS-0.97.2.pet, dia_NLS_IT-0.97.2.pet



\/ ENGLISH AT BOTTOM \/

Disponibile, nel mio repository, l'attuale Dia come pacchetto pet, fino alla nuova versione, dalla quale verrà sovrascritto.
NLS disponibili.

Prosit! :)

\/ ENGLISH \/

Available, in my repository, current Dia pet-packed, up to newer version, from which will be overwritten.
NLS available.

Prosit! :)

(Fonte immagine/image from: http://ts4.mm.bing.net/th?id=H.4543312055372147)



Posted on 1 Sep 2013, 16:03 - Category: Editors
No comments - Edit - Delete


Puppy Linux software: xampp-linux-1.8.3-0.sfs, hiawatha-9.2.pet




\/ ENGLISH AT BOTTOM \/

Disponibili, nel mio repository, gli attuali Xampp (sfs) e Hiawatha (pet), fino alla nuove versioni, dalle quali verranno sovrascritti.

Prosit! :)

\/ ENGLISH \/

Available, in my repository, current Xampp (sfs) and Hiawatha (pet) packed, up to newer versions, from which will be overwritten.

Prosit! :)

(Fonte immagine/image from: http://ts1.mm.bing.net/th?id=H.4761779823641860)



Posted on 1 Sep 2013, 1:26 - Category: Webservers, PHP, MySQL
No comments - Edit - Delete


Pages: [1] [2] [3]